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  1. Introduction


  Even if you have never used Adobe Photoshop before, I am pretty sure you’ve heard about it. The software is so iconic it’s become a verb: to “Photoshop” a photo means to edit it in a way that bends reality.


  Once you get your hands on Photoshop you become an owner of a fantastically powerful image editing tool. And this is why we are writing these guides  to help make your Photoshop experience easier and comfy. We have already covered a lot of tools, tips and tricks of Photoshop CS5 in our previous guides (Part I, II, III and IV), so I thought people would have had enough of Photoshop manuals by now. But then CS6 came out.


  Compared to earlier updates, CS6 is huge  I would even say revolutionary. This update brought many improvements to the interface and performance. There are also more “magic” tools, which enhance the entire workflow a lot, making our lives much easier. So, it is now obvious that these guys at Adobe really check users’ feedback and wishes. Hands down.


  In this guide, I will introduce you to the new features of Photoshop CS6 and show you what they are and how to use them.


  Please note, that I am using Windows, so Mac users will have to use slightly different key combinations (like the Command key instead of Ctrl, and Option instead of Alt).


  Ok. Let’s see what’s new! We’ll start with some tips and tricks.


  2. Tips and Tricks


  2.1. Quickly Change the Appearance of Photoshop CS6


  New appearance is the first thing that surprises a Photoshop user. If you have any experience in older Photoshop versions, you will see what I mean  the interface is dark now. This, in my opinion, makes you feel more comfortable and helps you concentrate on your image:
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  If you want to change the color scheme, use Shift+F2 (Mac: Shift+Fn+F2) to make it lighter and Shift+F1 (Mac: Shift+Fn+F1) to make it darker. There are 4 tones of grey to choose from:
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  Now, choose your favorite styling and let’s proceed.


  2.2. Background Save and Autorecovery


  Remember the last time you were working on some project and all of a sudden Photoshop crashed? I am sure you do  it’s always devastating. With CS6, you don’t have to worry about losing all your efforts and hard work in the case of a crash  when you reopen Photoshop it will recover the files you were working on.


  The new saving feature works on background and can be configured at Edit->Preferences->File Handling:


  [image: ]


  2.3. New Layer Features


  Photoshop CS6 comes with some awesome improvements on Layers as well. Now you can filter them by an attribute, search by name, apply blend mode to multiple layers, and even more.


  Let’s go through some of those features one by one.


  2.3.1. Filtering


  When working on a complex project in Photoshop we always end up with a pile of layers. Focused more on the creative side of the work, I actually forget to name those layers and end up with something like Layer 46, Layer 89, etc. Sound familiar? Then you will like this new feature.


  You can quickly find layers by their Kind (Pixel layers, Adjustment layers, Type layers, Shape layers or Smart objects), Name (write a layers name), Effect (Blending options), Mode, Attribute and by Color:
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  Here’s a reference table I’ve prepared for you:
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  2.3.2. Show Transform Controls


  This feature is a little one but I am sure many of you will find it handy. Now you don’t have to use Ctrl+T to show Transform Controls for a selected object or a layer every time. You can tell Photoshop to automatically show them for you  just check that option on Move (V) tool’s options panel:
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  2.3.3. Assigning Blend Modes to Multiple Layers or Groups


  In CS6 you can apply a blend mode to multiple layers and/or groups. Just select the desired layers and/or groups and choose a blend mode as usual. Let’s see how it works.


  I’ve selected a layer with a smart object and a group of text layers:
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  Next, I will apply a blend mode to them. I chose Multiply:
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  As you see, it has applied the blend mode to all selected layers (even though some text layers had a layer style).


  2.3.4. Applying a Layer Style to a Group


  Another handy layer feature! I think it will be most useful when it comes to styling text layers. Sometimes you have multiple layers that you want to assign the same layer style to (Blending options). Before, you had to apply effects to one layer and then Copy Layer Style and Paste Layer Style to another. Now it’s easier.


  You can group layers (Ctrl+G) that you want to have the same Layer Style and assign effects to that group:
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  And voilà! You have one Layer style for all layers in that group now:
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  Note: All new layers that you create in that group will inherit the group style.


  Small tip: if you are using multiple text layers, it is better to set all text color to white before assigning a new layer style.


  2.3.5. Rasterize Layer Style


  Finally arrived! I remember applying a layer style and then, to flatten it, I had to create an empty layer and merge those two. Maybe you had it the other way. But now it’s done directly from the right-click menu:
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  Note: this can be done with multiple layers.


  Small tip: it is always a good idea to mark certain layers with their own color, just for a quicker reference and it’s quicker than naming them:
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  I think I’ve covered the most important layer features. So let’s proceed.


  2.4. Auto-Hide Panels


  There are a lot of panels in Photoshop, and before CS6 you had to close each one of them after using, in order to get more space and save yourself from this:
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  Ok, I know: I am exaggerating. Still: you always had to minimize a panel after usage. Starting with CS6 you can set those panels to Auto-Collapse Iconic Panels (Edit->Preferences->Interface):


  [image: ]


  After clicking OK you will not have to minimize a panel to icon manually  it will hide automatically. And it is a time-saver for me!


  2.5. Add Dotted and Dashed Lines


  This one came as another small and sweet surprise to me. From now on, adding a dotted or a dashed line is a piece of cake, since the Line tool has more options.


  Just select the Line tool and from tool options panel choose dotted or dashed style:


  [image: ]


  2.6. Add Strokes to Shapes without Layer Styles


  Another cool addition to Shapes is that starting with CS6 you can add Strokes of any type with a few clicks. Before, you had to do it through Layer Styles (Blending Options).


  Create any shape and take a look at the options panel:
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  As you see, it has options for Fill and Stroke. You can choose from a solid color, a gradient or a pattern for both.


  3. Tweaking Images


  Photoshop CS6 comes with some awesome new tools for more professional and creative image editing. These include new Blur filters, improved Gradient map presets, smarter Crop tool, skin tone detection, more content-aware tools, Oil paint and more. Let’s see what they look like.


  3.1. New Blur Gallery


  Blur effect gives depth to an image, it lets you focus on the main objects in a photo.


  Photographers don’t always have a proper camera or lens to take a correctly focused picture, and that’s when those filters come in handy. Even better: Photoshop now lets you create blur effects that can’t be achieved with a camera.


  Before CS6, Photoshop had some simple blur filters we could make use of, and we did. Photoshop CS6 comes with such an amazing Blur gallery that I fell in love with it.


  You will too.


  The new Blur gallery can be considered as a built-in program. And thanks to the new engine, it is really powerful  you do everything on-the-go, focus points are determined by adjustable pins and you can forget the old tiny preview windows!


  When you activate it (Filter->Blur->Field Blur or ->Iris Blur or ->Tilt-Shift), it opens the Blur gallery interface:
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  Note: it doesn’t matter which Blur tool you select first, since you can always choose one of the three from Blur tools widget.


  Let’s follow the list and check those Blur tools one by one.


  3.1.1. Field Blur


  At first sight, Field Blur looks very simple and plain  well, it just blurs the whole image. But in the right hands it can do cool things.


  Just by putting three pins with different blur values you can isolate a desired area of your image:
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  Tips: You can use as many pins as you need. To remove a pin, click on it and hit Delete on your keyboard. You can drag pins and adjust blur amount by dragging the “blur ring” up or down (just like a volume controller):
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  Here’s a quick example of using the Field blur:
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  3.1.2. Iris Blur


  This tool simulates a camera lens blur, and gives you more control over the size of the focus and its shape.


  The shape of the focal area can be changed from elliptic to rectangular:
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  Tip: you can drag one of the four feather handles individually by holding the Alt key.


  Here’s an example of using the Iris blur:
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  3.1.3. Tilt-Shift


  Tilt-Shift is my favorite. It gives a “miniaturizing” effect to a normal photo, after which the same objects look like toys. And it is always a good idea to choose the right image for it  a lonely house in the midst of a forest, a nature scene, busy sidewalk, etc., and the best angle is bird’s eye view. Of course you’re not limited to those, but it’s easier to work with such photos.


  I’ve chosen a photograph from stockvault.net (where you can get free photos for your work):
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  Let’s apply the tilt-shift effect to it.


  Go to Filter->Blur->Tilt-Shift:
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  As you see, there are many on-screen controls, which you can drag to change the whole effect.


  The houses are not in focus now, so I will drag the pin lower and I will rotate it a little by dragging the rotation handle. Then I will narrow the feather lines and the focus lines:
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  Note: the Tilt-Shift widget has more options  Distortion amount and Symmetric distortion. If you apply a positive amount of distortion it will add a zooming effect to the blur area; if you apply a negative amount, then it will add a radial motion blur. And if you turn on the Symmetric distortion, the distortion effect will be applied to both sides.


  You’re done:
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  3.1.4. Bokeh Effect


  All three new blur tools have an additional panel, where you can add the Bokeh effect, which blurs the out-of-focus points of light. Make use of it when needed:


  [image: ]


  And an example:
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  3.2. Color Lookup


  This feature helps you quickly change the color scheme of your image. Accessible through Adjustments panel (Window->Adjustments).


  There are three groups of presets  3DLUT, Abstract and Device link, and each group has some nice “looks” to use:


  3DLUT presets:
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  Abstract presets:
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  Device link presets:
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  3.3. New Auto Presets


  Most of the advanced Photoshop users never use Auto features, because it doesn’t work well and the results are usually not professional-grade. But with CS6 those features are improved dramatically: these features are fairly reliable now.


  Now there’s an Auto button in the Brightness/Contrast, Levels and Curves dialog boxes:
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  I wish I could give you some screenshots to show the difference, but I got rid of CS5 already  no before and after shots today. But, please believe, I never used the Auto features before, but now I will. I think it will be most useful when you need to correct some nice photos, quickly.


  3.4. New Crop Features


  The Crop tool has got new features as well! It is much smarter and more convenient now. You’ll see the differences when you first click on the Crop tool  it has more handles and more settings in the options menu:
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  You can use a fixed size crop box by choosing preset values, you can change the orientation of the crop box (landscape or portrait), straighten an image by drawing a line, change the grid view, enable deleting the pixels that are left out of the box.


  Also, you will realize that when you rotate or move the crop box, you are actually moving the image and you can see the unwanted area that is left out of the box, without working “blind” as it was before.


  Let’s see how Straighten works.


  Say you have a photo and you’re not satisfied with its orientation:
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  To straighten it, click on the Straighten icon from the options panel and draw a line, which the Photoshop will use as a reference:
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  Then you have this:
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  Hit Enter. Done.


  As you see, it rotates the image and crops it “smartly”, without empty spaces.


  3.5. Adaptive Wide Angle


  Another amazing tool that comes with CS6 is the Adaptive Wide Angle. It lets you correct any distortions created by camera lenses, like perspective, fisheye, wide angle, etc. Sometimes you want to correct those things. Here’s a quick example:
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  As you see, I’ve removed the odd perspective from the original image.


  Before CS6, we had only the Lens Correction feature (which is still there), but it doesn’t give you as much control over the image. Adaptive Wide Angle reads the meta data that comes within the photo and detects all available info about the camera and its lens, and lets you correct distortions by drawing lines. Moreover, even if there’s no metadata, you are still able to correct things.


  Let’s see how it works.


  Open your image and go to Filter->Adaptive Wide Angle:
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  As I said, it reads the metadata and suggests a correction mode. In my case it’s Perspective. You can always adjust the Scale, Focal Length and Crop Factor, or change the correction mode, but I leave it with As Shot checked.


  Ok, so we are here to correct the distortions. It’s pretty simple and straightforward  draw lines, “telling” Photoshop “this should be straight”:
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  Tip: when you hold Shift while drawing a line, you force it to be 100% vertical or horizontal.


  That’s it, a little practice and you will love the tool. As for the empty areas  crop them and we have Content-Aware Fill, remember?


  We all loved it when Adobe presented the Content-Aware family of tools, right? So, they didn’t stop there. Photoshop CS6 comes with two new Content-Aware tools  Content-Aware Patch and Content-Aware Move.


  3.5. Content-Aware Patch


  It’s more like an addition to the old Patch tool. You have to choose it from the Patch tool’s options panel:
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  Content-Aware Patch tool comes in handy when you need to remove things from an image. And it is better if the area around your selection is pattern-like (grass, wall, sand, snow, sky, clouds, etc.).


  To use it, make a quick selection around the unwanted object and drag it to an area that you want it to be like:
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  Pretty good:
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  3.6. Content-Aware Move


  This new tool makes it easier to move objects within a photo, without worrying about making super precise selections. Just quick-select an object (I use Quick Selection tool) and use the Content-Aware Move tool to move it elsewhere:
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  Small tip: for smoother results, when you use Content-Aware tools, it is better to expand your selection a bit  Select->Modify->Expand (like 7 px or more, depending on the size of the image).


  Now select the Content-Aware Move tool and move the horse to the right:
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  Nice job for a quick move, isn’t it? At least it’s a good starting point. You can always fix things with Content-Aware Spot Healing brush.


  There’s an Extend mode in the options panel of the Content-Aware Move tool:
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  You can use this tool when you need to extend some objects. Make a selection of some part of the object, select Extend mode and “stretch” it:
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  I’ve applied this to three of the stones. Check the difference:
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  3.7. Selecting Skin Tones


  This feature is a little one, but really helpful. Now you can tell Photoshop to select the skin tones of people on your photos. It’s a time-saver, since now you don’t have to do it manually.


  It’s actually an addition to the existing Color Range feature, found in Select menu:
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  Select a portrait, open it in Photoshop, go to Color Range and select Skin tones from the drop-down menu. You can turn on Detect Faces and see if you get a better selection. Play around with Fuzziness (the greater the value  the more area will be selected) and once you’re satisfied, click OK:
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  Tip: don’t worry about the excess selection, you can get rid of them quickly through Quick Mask Mode (Q)  activate the Quick Mask mode, select a default round brush and paint over the unwanted areas. And don’t forget to go back to normal view.
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  Now you can do anything you want with the skin.


  Note: Select Skin Tones works better with portraits.


  3.8. Oil Paint


  Here’s another tool to give your images an artistic look  new Oil Paint filter (Filter->Oil Paint). It has enough controls and options for you to create a realistic oil paint picture, from how sharp or smooth the brush is to where the light comes from and how thick or thin the bristles are:
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  This filter is a lot of fun and there’s no limit to what you may come up with. Here’s my quick example:
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  3.9. HDR Toning


  First off, what’s HDR (or HDRI)? It stands for High Dynamic Range Imaging. In simple terms, HDR images are made by combining multiple exposures of the same image. “The intention of HDRI is to accurately represent the wide range of intensity levels found in real scenes ranging from direct sunlight to shadows,”  says Wikipedia.


  Skip the terminology, HDR images are very rich and cool.


  With Photoshop CS6 in your hands, you can achieve similar effect with one single image. Open an image and head on to Image->Adjustments->HDR Toning:
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  The HDR Toning interface gives you tremendous flexibilities over the image. Every image is different and every photographer has his or her own style, so you are not limited to any presets or defaults  free your mind.


  But still, those presets can give you a nice starting point. The Method drop-down menu has pre-defined groups of adjustments; if you want full control  choose Local Adaptation.


  Here are some quick examples:
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  I think that’ll be it for new features. Please note that these are not all of the new features of CS6, I’ve just covered the most used ones. Other updates include 3D tool improvements, new brush features (those I didn’t include just because I don’t use a stylus yet), Adobe Camera RAW enhancements, improved Video editor and more.


  But I promise to explain them in the near future.


  Now, before saying “bye bye”, I’ll show you some tips on speeding up your Photoshop CS6.


  4. Speed Up Photoshop CS6’s Performance


  First of all, let’s see what the CS6 system requirements are:


  Windows


  
    	Intel® Pentium® 4 or AMD Athlon® 64 processor



    	Microsoft® Windows® XP* with Service Pack 3 or Windows 7 with Service Pack 1 (recommended)



    	1GB of RAM



    	1GB of available hard-disk space for installation; additional free space required during installation (cannot install on removable flash storage devices)



    	1024x768 display (1280x800 recommended) with 16-bit color and 256MB (512MB recommended) of VRAM



    	OpenGL 2.0capable system



    	DVD-ROM drive


  


  Mac OS


  
    	Multicore Intel processor with 64-bit support



    	Mac OS X v10.6.8 or v10.7



    	1GB of RAM



    	2GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)



    	1024x768 display (1280x800 recommended) with 16-bit color and 256MB (512MB recommended) of VRAM



    	OpenGL 2.0capable system



    	DVD-ROM drive


  


  But those are minimum requirements. I work on a Windows desktop (4GB RAM, 1GB of VideoRAM) and still Photoshop freezes at times, or slows down when multitasking. So if you are on a slower machine, the tips I will provide will be useful for your workflow:


  
    	Close unused documents  every single image in Photoshop is a big memory consumer, so if you’re done with an image  close it and you will free some memory up;



    	Use Purge  every now and then use Edit->Purge All (it will delete all history, empty the clipboard) and it will feel like you’ve just opened Photoshop;



    	Disable Animated Zoom  go to Edit->Preferences->uncheck Animated Zoom;



    	Disable Flick Panning - go to Edit->Preferences->uncheck Enable Flick Panning;



    	Set Memory Usage to something like 70% - Edit->Preferences->Performance;



    	Add Scratch Disk(s) - Edit->Preferences->Performance;



    	Reduce the image resolution  if the final product is more likely to be used in a low resolution, reduce it to tolerable values and you will see that it works faster now;



    	Turn off image previews - Edit->Preferences->File Handling->Image Previews set to Never Save;



    	Work in Full Screen mode (hit “F” three times and then press Tab key to bring up the panels and tools)  some say it speeds Photoshop up.

  


  And of course, don’t forget about the system itself  close unnecessary programs, files, do not overload your machine, since every action requires memory and you don’t want your memory all used up.



  Upgrading your RAM, graphic card and the processor is always the best way though…


  5. Conclusion


  Another Photoshop guide is done and I hope it will help you master this awesome software. Photoshop is a huge universe to explore  one that keeps expanding  so I think there will be more guides in the future.


  If you have any suggestions, ideas, or comments  please, don’t hesitate to contact me: bohed.t@gmail.com
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