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1. Introduction                                                  

It’s my great pleasure to offer you another guide from our Photoshop series. I hope you have downloaded and read 
the first three parts (Part I, II and III) already, since you will need that knowledge as you go through this guide.

The team at Adobe does some really great work, surprising and amazing us with new features. When you buy your 
copy of Photoshop you get more than you thought you would. This guide, like the guides before it, is intended to help 
you explore this powerful and multifunctional program. Once you have it and learn how to use it you will have a profes-
sional image processing lab on your computer.

To master this lab, you need to practice. I say it all the time - the more tutorials and guides you go through, the more 
methods and tools you will have at your disposal. But reading isn’t enough. To really learn, you need to open Photo-
shop and follow the steps outlined. Do that with this manual and you’ll pick up some new skills.  

In this guide, I’ll show you how to make use of some amazing features that came with CS5, such as Content-Aware 
and Puppet Warp, along with some tools that we had before CS5.

Some tools are overlooked by users, even Photoshop veterans, but that doesn’t mean those tools can’t make your life 
easier and enhance your workflow. We’ll go through some of them as well.

Also, I will show you how to create a basic animation in Photoshop and how to use it to create a morphing effect.

Note that in most cases I will skip basic explanations, assuming that you are familiar with basic tools and techniques 
(which were already described in previous guides). However, I will try to make things as simple as possible.

Also note that I’m using Windows, so Mac users will have to use slightly different key combinations (like the Command 
key instead of Ctrl, and Option instead of Alt).

http://www.makeuseof.com
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2. Content –Aware Feature                                     

Every Photoshop user was excited when they first heard about Content-Aware. The Adobe team released videos 
showing how awesome the feature is and they spread like wildfire. This makes sense - it is an awesome feature - but 
it’s important to realize these videos use “best-case” scenarios, like removing some tiny trash from a grassy back-
ground, a lonely tree standing in the middle of a field and so on. 

The thing is that the Content-Aware tool uses surrounding information, trying to “guess” what is supposed to be in the 
selection you’ve chosen. So when you use Content–Aware to remove a ball from a soccer field, it’s pretty easy:

Open your image in Photoshop and make a quick selection around the ball and its shadow (you don’t have to be pre-
cise):

Apply Content-Aware Fill (right-click -> Fill… or Shift+F5 and select Content-Aware):

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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The result is not bad for a few seconds’ work:

That was an easy job for Photoshop. So when you have an object much smaller than the surroundings, and relatively 
consistent surroundings, you can use this method to get a quick result.

2.1 Spot Healing Brush Tool

Sometimes you will get unwanted artifacts after applying Content-Aware Fill. Here comes another new Content-Aware 
tool called Spot Healing Brush Tool:

Make sure it is set to Content-Aware in the upper options panel:

Using this tool is similar to using the normal Brush tool. Just “paint” over the unwanted object and you’re done:

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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There’s a lot of talk on the Internet about which one of these methods is best. I would say a combination of both tools 
is the best practice. 

Some tips for better results:

a) The higher the image resolution, the better;

b) Make selections a bit bigger than the object;

c) For small objects use the Spot Healing Brush Tool;

d) It is better to use the Spot Healing Brush Tool when removing lines (wires, sticks, traffic signs, tubes, etc.);

e) Do not rely on Content-Aware completely: in most cases you will need to fix things “manually” to get better results.

2.2 Content-Aware Scale

Another tool that has the Content-Aware feature is Content-Aware Scale. (Edit->Content-Aware Scale)

This basically lets you scale an image with-
out distorting its primary subjects. You might 
have seen presentation videos on this too, 
but again, these videos represent “best case” 
scenarios.

Reality is not as perfect. It doesn’t help much 
when applied to images with backgrounds 
containing more than just a gradient, sky, wa-
ter, grass, etc. If you try it on a regular photo 
with many details on the background, you will 
see that it distorts just about everything.

Knowing that, how can you best make use of 
Content Aware Scale? In my opinion, this tool 
is best used when you need to turn a hori-
zontal (album) photo into a vertical (portrait) 
one. Let’s try doing that. 

Select an image with a simpler background. 
I’ve chosen Kobe Bryant going for a slam 
dunk. 

http://www.makeuseof.com
http://smidgenpc.com/
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Open your image in Photoshop; unlock the Background layer by double-clicking on it. Go to Edit->Content-Aware 
Scale and scale it from left to right:

Wow, the result is amazing! It didn’t touch our Kobe at all while scaling the background. If you compare the final image 
to the original you will see the changes:

http://www.makeuseof.com
http://smidgenpc.com/
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See how it played with the lights?

OK, this was too easy.

Sometimes, when you edit a photo, you have to cut or scale the image and it comes with white spaces when printed. It 
happens because there are certain proportions you have to keep for the printer.

You can use the Crop (C) tool’s presets in the upper settings menu:

Let’s say you have edited an image and the final version of it doesn’t have the right proportions, like this:

Let’s say that, for printing, we want a 5 inch x 3 inch photo. Set the Crop tool’s size to 5 inch by 3 inch from Tool Pre-
sets (see above) and apply it to the image:

http://www.makeuseof.com
http://smidgenpc.com/
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We have some empty area to fill now, so we’ll use the Content-Aware Scale tool, using its Protect option. It is used 
to protect important objects from distortion. 

First, make a quick selection around objects that you want to protect. In our example those objects are ducks:

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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Save the selection (from the right-click menu):

Deselect (Ctrl+D). Select the Content-Aware Scale tool (from the Edit menu) and choose your saved selection from 
the drop-down list right next to the “Protect” option:

Now, our ducks are protected and you can stretch your image:

http://www.makeuseof.com
http://smidgenpc.com/
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Pretty good, isn’t it? Our ducks are not distorted and feeling just as fine as before. And our background looks pretty 
natural.

There’s also a Protect Skin tones option (a button with a human silhouette), which is best used when you have a hu-
man being as the main object. But I suggest protecting saved selections instead.

Some quick tips for the Content-Aware Scale tool:

a) If you are scaling the image in multiple directions, it is better to apply changes after each step. For example: do you 
need to scale vertically and horizontally? Scale in one direction and hit enter (or double-click) and then scale in the 
other direction and apply;

b) It is best used when you have an image for printing and need to seamlessly transform the background. Also, it’s better 
to use the Content-Aware Scale when you want to make a portrait image out of a horizontal one, or vice versa;

Conclusion
As you see, the Content-Aware feature is great - but do not rely on it completely. The tool won’t give you a perfect 
result, so to get the best results you will still need to do some work after applying it. Let’s say it’s a time-saver, which 
gives you a nice starting point to work with. Play around, try different selections and you will see that it gives different 
results every time you apply it.

http://www.makeuseof.com
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3. Puppet Warp                                               

Another amazing tool that came with CS5 is Puppet Warp.(Edit->Puppet Warp)

This tool helps you bend things (for example: body parts). You may have seen images where a giraffe’s neck has 
clearly been bent - that’s a crazy example of what this can do. The Puppet Warp tool lets you create “bending points” 
or hinges, so you can easily bend any selection (or a part of it).

Confused? Don’t be. Let’s try an example. Here’s a lovely picture of my wife with terrible posture. Let’s fix that. 

Open your image in Photoshop and make a quick selection:

http://www.makeuseof.com
http://smidgenpc.com/
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Copy and paste it. Deselect (Ctrl+D) it and turn the new layer into a Smart object (right-click on the layer and select 
Convert to Smart Object). This is a very handy tip, since it lets you re-edit the changes you made with Puppet Warp 
later, instead of applying everything from the beginning.

Go to Edit->Puppet Warp:

Now you need to create pins (hinges). Click on places which you want to “freeze” (usually these are the points where 
our limbs bend):

Now you can pull and drag and rotate those pins. Make your changes and hit enter when you’re satisfied:

http://www.makeuseof.com
http://smidgenpc.com/
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At this moment we can make use of the Spot Healing Brush tool (set to Content-Aware) to paint the original image’s 
details in the background layer:

Of course, it’s just a quick example to show you a way to use the Puppet Warp. You can use it in many other ways - 
straightening lines, correcting lens distortion, bending a giraffe’s neck, and more. 

Some quick tips:

a) Add more pins to avoid distortion, but place them well;

b) Hold Shift to choose multiple pins;

c) Apply Pin Depth when overlapping

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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4. Working With 3D In Photoshop                        

Before I start this chapter you should know - 3D in Photoshop CS5 is a huge topic, and may even be considered as 
a brand new world within the Photoshop universe. It is impossible to mention everything about it, but I will give you a 
brief introduction. Let’s work through some basic examples.

4.1 Creating a 3D text with Repousse
Create a new document and write some text. Go to 3D->Repousse->Text layer…:

In this box of settings you can do a lot of changes with your text, but this time we’ll do some basics only. Let’s apply 
the brick texture to the front side of our text. Choose Stone brick from the dropdown menu in Materials:

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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And keep the other settings at default. Click OK:

You can still edit your 3D text effects in 3D Panel (Window->3D):

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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You have full control over every single detail there – from textures to light sources and so on. To get more familiar with 
them, all you need is more practice.

Also, you can easily rotate and move your 3D shape (this time it’s the text we just created) in all directions by using 
the Object Rotate Tool (K) or the Camera Rotate Tool (N):

Once you’re done, right-click on the 3D text layer and select Rasterize 3D.

As you proceed with mastering the 3D feature of CS5 you will see how amazing it can be. There are also lots of free 
and - of course - paid materials and shapes to make your work easier.

4.2 Creating a 3D Christmas Ball Using Your Own Photos
Of course, there are different ways of creating a Christmas ball in Photoshop, but I want to show you how you can use 
custom textures for your 3D objects.

Create a new document and create a Sphere (3D->New Shape from Layer->Sphere):

As you see in your Layers panel, there’s a Diffuse section under Textures. Double-click on Background there to edit 
the texture:

http://www.makeuseof.com
http://smidgenpc.com/
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It will open a new document. Whatever you do here will be your texture.

Fill the layer with blue (I chose #0b57f0) and create some middle size snowflakes by using Custom Shape tool and 
Merge all layers (or you can use Flatten Image):

Let’s add some Noise (Filter->Noise->Add Noise):

Close the current document and click Yes when asked to save changes.

As you see, our Sphere now has some nice texture:

http://www.makeuseof.com
http://smidgenpc.com/
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You can adjust everything from the 3D panel. For example, let’s make it brighter. Select Infinite Light 1 and set Inten-
sity to 1,88:

That’s almost it, now you can add background, a shadow, etc., but finally, you will have to render this 3D object, or 
Rasterize 3D.

You can set Render Quality in the 3D panel. Click on Scene and set Quality under Render Settings to Ray Traced 
Draft (or Ray Traced Final for better quality, but it’s a slow process):

Note: When you change the Render Quality, you will see that it starts to calculate with blue blocks running through 
your document. It Renders. You can stop the process at any time by clicking somewhere on the document.

You’re done. Just right-click on your 3D layer and choose Rasterize 3D.

http://www.makeuseof.com
http://smidgenpc.com/
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4.3 Downloading extra 3D content
To download extra 3D content, go to 3D->Browser 3D Content Online. Photoshop will open your Internet browser and 
take you to the official extensions page, where you can choose what to download or buy.

First, let’s get some materials. They are free. Click 
on Versatile Materials and download the .zxp file 
to your computer. Once downloaded, double-click 
on it and it should open Adobe Extension Manager 
and automatically install the extension for you.

Now you have 100+ materials in several catego-
ries, including Fabrics, Glass, Organics, Tiles, Fun, 
Metal, Stone, and Wood more.

To import a 3D model into your document, just 
download one and drag and drop the .3ds file into 
Photoshop.

One important tip for a better experience when 
working with 3D – the more powerful your machine 
is –the faster and better your results will be. You 
will probably need at least 4GB of RAM and 1GB 
of video RAM. Everything will still slow down while 
rendering, so don’t plan on multi-tasking. 

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com


PHOTOSHOP FOR IDIOTS, PART 4

22
HTTP://MAKEUSEOF.COM
HTTP://TRUEKOLOR.NET, AZAMAT “BOHED” E.

5. Background Eraser                                       

If you have overlooked this tool, I suggest you try it again. It’s another approach to making selections and getting rid of 
unwanted backgrounds.  

Let’s go straight to examples.

I have a photo, where I hold a butterfly. I want to separate that creature from myself, so I open it in Photoshop and 
select the Background Eraser tool:

We have some options for this tool. Let’s set Sampling to Once and Tolerance to 30%:

Now, hold Alt and click on background closer to our butterfly to select unwanted color.

I’ve Alt+clicked on the t-shirt and now I can easily erase everything around the butterfly (preserving even the anten-
na!):

http://www.makeuseof.com
http://smidgenpc.com/
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Note: for better results, I’ve Alt+clicked on skin when I approached it; and I played with the brush size and tolerance in 
different places.

Now we can use our butterfly anywhere we want:

The Background Eraser comes in handy when you need to get rid of unwanted background around an object. It works 
great even with grass, trees, wires, fur and such.

http://www.makeuseof.com
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6. Morphing A Face In Photoshop (Basics)          

 Basically, morphing is transforming from one thing to another. 

Let’s create an animation, where a face morphs from normal to “weird”.

Open a face image in Photoshop and duplicate it (Ctrl+J):

Now we’ll use the Liquify tool to distort the face in a funny way.

6.1 Liquify tool
Go to Filter->Liquify…:

http://www.makeuseof.com
http://smidgenpc.com/
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The tools we’ll use are highlighted with red (Forward Warp Tool, Pucker and Bloat).

I used Forward Warp Tool to stretch ears, Pucker Tool to shrink the nose and mouth and Bloat tool to make eyes big-
ger:

Let’s change the skin color to some bright blue. Select the Color Replacement Tool, set foreground color to blue and 
just paint over the face:

Now we’ll create an animation.

6.2 Creating an Animation
If you’ve never created an animation in Photoshop, you will learn the basics now. It’s pretty easy.

To activate the Animation panel go to Window->Animation. You will see the Timeline view or Frames:

http://www.makeuseof.com
http://smidgenpc.com/
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This time we’ll use the Frames view (to switch between the two, click on the small icon in red).

Create a new frame by clicking the Duplicate icon:

Select the first frame and make the layer with the blue face invisible, then go to the next frame and show the blue face 
layer (keep the original layer visible on the second frame):

The idea is to show one layer on the first frame and another layer on the next frame.

Now we’ll create the morphing effect.

Shift+select both frames and click on the Tween icon:

http://www.makeuseof.com
http://smidgenpc.com/
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Set as following and click OK:

Now you should have 7 frames, slowly transforming from the original face to blue.

Select all frames (Shift + select) and click on the Timing icon (in red) to set the delay between frames to 0 sec (No 
delay); click on looping options (in green) and select Forever:

You can test your animation by clicking on the Play button. Pretty cool, isn’t it?

Click here to check out the GIF online!

Let’s add reverse frames for a better effect. Select all frames again and in the animation panel’s top-right corner menu 
select Copy frames:

http://www.makeuseof.com
http://smidgenpc.com/
http://www.makeuseof.com
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Click on Paste frames from the same menu and select Paste after selection and click OK:

Now we have duplicated 7 frames, but they’re in the wrong “direction”. Click on that top-right menu again and select 
Reverse frames (make sure that the last 7 frames are selected after pasting). Done! 

You can set the delay time to 1 sec (for example) for the last frame to let it freeze for a while.

Now it’s time to save it for Web in GIF and use it wherever you want:

You can make the image size smaller so that the file size is not too big.

http://www.makeuseof.com
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7. Quick Tips On Speeding Up Photoshop CS5   

Most Photoshop users think that they are getting the most out of it without any settings changed. Well, I am not talking 
about monster machines, but those who work with Photoshop on average computers will find those tips useful.

Photoshop’s performance depends on your RAM - the more RAM you have, the faster your workflow. At the very least, 
you will need 2GB of RAM to work with the program, but even then you will face “slow-downs” when working with 
many layers, high-resolution images and brushes. Moreover, if you have lots of fonts, it will slow down on startup.

7.1. Check Memory Usage
Go to Edit->Preferences->Performance and if you have more than 4GB of RAM then set it to 70%-75%, if less than 
4GB – 50%-55% is enough.

7.2. Enable 3D VRAM
If you are running Photoshop CS5 Extended, then you can enable 3D VRAM and set it to 100%. If your Video Card 
has available RAM, this will speed up your experience when using 3D tools. Go to Edit->Preferences->3D:

7.3. Scratch Disks
If you have more than one hard disk or partitions you can assign them as scratch disks for Photoshop, which will 
speed up for real.

http://www.makeuseof.com
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7.4. Use Purge
What’s Purge? Mostly, people overlook it, but it’s very useful. It cleans up your clipboard. Go to Edit->Purge. Use it 
regularly, but remember, save your work before purging, since it erases your undo’s, clipboard and histories.

7.5. Layer Thumbnails
When you have a lot of layers it is suggested to set your layer thumbnails to Small. Every time you edit a layer it has 
to update its thumbnail, which eats some RAM. To set Layer thumbnail size, right-click somewhere on Layers panel 
and choose the Small size:

Other Small Tips
Close documents and software which are not required for your current job. Turn off the Navigation panel if it is on. Get 
rid of unnecessary fonts. Upgrade your system whenever you can!

I hope those tips will help you out. 

http://www.makeuseof.com
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Conclusion                                                       
I believe you are now much closer to mastering Photoshop. This guide might be the last one for now, but with CS6 
coming out soon, I think the next Photoshop guide will cover some amazing new features (there are some really cool 
things to come!). 

Remember that your feedback is always welcome and if you have any suggestions or ideas, please don’t hesitate to 
contact us.

http://www.makeuseof.com
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